Intermittent issue with adding payment methods
Incident Report for AuthVia
Resolved
This incident has been resolved.
Posted Jun 28, 2023 - 14:30 PDT
Monitoring
Our team will continue to monitor the system closely to ensure that the implemented solution effectively mitigates the problem. In case of any further incidents or related issues, immediate action will be taken to rectify them and minimize any impact on payment processing.

Within the solution customers may see 2 messages; one with the payment being declined and one saying the payment went through. These message will come in fast succession.
Posted Jun 28, 2023 - 14:17 PDT
Identified
Description:
An issue was identified with the logic governing older payment requests, specifically those created before June 20th, 2023. The system failed to appropriately consider or update the permission of the merchant to utilize a payment method when the customer granted permission for payment processing. As a result, intermittent problems arose in approximately 6% of transactions.
Resolution:
To address this issue, our team implemented a solution that includes handling for the problem scenario. While this solution ensures successful payments, it may cause a slight delay in processing times for affected transactions.
Posted Jun 28, 2023 - 13:45 PDT
Investigating
Payment methods are not getting the correct permissions causing some transactions to fail
Posted Jun 28, 2023 - 11:08 PDT
This incident affected: lock.authvia.com.