Payout's are failing from one of our partners
Incident Report for AuthVia
Resolved
This incident has been resolved.
Posted Nov 12, 2024 - 08:50 PST
Investigating
Payout's are failing from one of our partners
Payments are unaffected
Posted Nov 12, 2024 - 07:20 PST